0
Answered

Sharing an image collection to facebook

Sarah McCraley 4 years ago updated 4 years ago 3

When I share an image collection from our site to facebook - the post does not pull any image assets or even our logo into the post. When I share an article and individual images it works fine. See my screen shot of the two posts. The top is an image asset, the bottom post is a collection. We try to use collection assets throughout our site. It would be nice if the sharing of collections displayed consistently with the other types of assets.



Answer

Answer
Answered

Hi Sarah!


That article of the adorable sloth does have an og_image correctly associated, and it is the right size, so this appears to be a problem that was identified in this post here:

http://community.townnews.com/topics/433-facebook-refuses-to-pull-child-images/


Essentially, especially on the first share, Facebook sometimes does not get the image due to async loading. This is a newish issue with Facebook, but they have a new method that we hope will fix it (which we are implementing in the next few weeks).

In addition, see my best practices in that link above. If you as an editor (or anyone in the newsroom) triggers a Facebook share when the page is not ready, Facebook will give an error which leads to the issue above.


We have several initiatives to workaround the scraping mechanism changes from Facebook. But for now, you can go to:


And run the URL through it a few times (until it should the proper preview at the bottom) and that will fix it. Obviously this is not ideal for every situation, which is why we are attempting to add more features to help workaround these Facebook issues.

We frequently push Collections to Facebook as well and we usually do get the normal preview image like you are expecting. I'll keep an eye out when I do the next one just in case.

Answer
Answered

Hi Sarah!


That article of the adorable sloth does have an og_image correctly associated, and it is the right size, so this appears to be a problem that was identified in this post here:

http://community.townnews.com/topics/433-facebook-refuses-to-pull-child-images/


Essentially, especially on the first share, Facebook sometimes does not get the image due to async loading. This is a newish issue with Facebook, but they have a new method that we hope will fix it (which we are implementing in the next few weeks).

In addition, see my best practices in that link above. If you as an editor (or anyone in the newsroom) triggers a Facebook share when the page is not ready, Facebook will give an error which leads to the issue above.


We have several initiatives to workaround the scraping mechanism changes from Facebook. But for now, you can go to:


And run the URL through it a few times (until it should the proper preview at the bottom) and that will fix it. Obviously this is not ideal for every situation, which is why we are attempting to add more features to help workaround these Facebook issues.

Okay thanks. I will remember that for the future. I notice it happens a lot on our collections.