Your comments

The image asset's presentation field has moved out of the Other tab and to the bottom of the editor's main work area, next to the display priority field:

Clicking the checkbox column header twice will clear all selections:

You can also right-click on the asset list and choose 'Select none' from the menu: